Дані Calc

Матеріал з Вікі ЦДПУ
Перейти до: навігація, пошук

Робота з стовпцями та рядками аркуша

Кожен аркуш книги Calc розбитий на стовпці, які позначаються літерами (від А до AMJ), і 65 536 пронумерованих рядків. Стовпці і рядки в аркуші можна видаляти, додавати, об'єднувати, переміщати разом з даними і без них і т. д. Стандартна ширина стовпців і висота рядків також може легко змінюватися довільним чином.

Робота з рядками

Виділення рядка
Перший спосіб:
У вікні відкритої таблиці клацніть по номеру потрібного рядка лівою кнопкою миші з курсором-стрілкою.
Другий спосіб:
У вікні відритої таблиці виділіть будь-яку клітинку потрібного рядка і використайте сполучення клавіш Shift + Space (клавіша пробілу).
Третій спосіб:

  1. У вікні відкритої таблиці клацніть курсором введення тексту в адресному віконці на рядку формул.
  2. Введіть адресу рядка, наприклад: A2: AMJ2, де А2 вказує на першу клітинку рядка, а AMJ2 - на останню клітинку рядка.
    Назву стовпця можна вводити без урахування регістру.
  3. Закріпіть введення натисненням клавіші Enter.

Виділення кількох рядків підряд
Перший спосіб:
У вікні відкритої таблиці протягніть курсор-стрілку за номерами потрібних рядків при натиснутій лівій кнопці миші.
Другий спосіб:

  1. У вікні відкритої таблиці клацніть в адресному віконці на рядку формул.
  2. Наберіть адресу діапазону рядків: адреса першої комірки першого рядка, двокрапка, адреса останньої клітинки останнього потрібного рядка, наприклад: A2: AMJ9, де А2 вказує на першу комірку рядка перші рядки, а AMJ9 - на останню комірку останнього рядка діапазону.
  3. Закріпіть введення натисненням клавіші Enter.
    Даний спосіб зручний для виділення строк за межами видимості на аркуші.

Виділення кількох рядків не підряд
У вікні відкритого аркуша клацайте за номерами потрібних рядків курсором - стрілкою, утримуючи клавішу Ctrl.

Висота рядка

Висота рядків задається в сантиметрах. При цьому вона може бути точною, вільною та оптимальною.

Зміна висоти рядка
У вікні відкритої таблиці наведіть курсор на роздільник під номером потрібного рядка і при натиснутій лівій кнопці миші перетягніть вгору або вниз.

Висота за вмістом рядка
У вікні відкритої таблиці наведіть курсор на роздільник під номером потрібного рядка і двічі клацніть лівою кнопкою миші.

Задання точної висоти рядка

  1. У вікні відкритої таблиці виділіть потрібний рядок або діапазон рядків.
  2. Відкрийте меню Формат і у списку команд наведіть курсор на пункт Строка.
  3. У додатковому меню виберіть пункт Высота.
  4. У вікні Высота строки (Рис. 2.2.1) задайте регулятором Высота потрібне значення.
    Максимальна висота рядка дорівнює 100 см.
  5. Закрийте вікно кнопкою ОК.
Рис. 2.2.1 Вікно Высота строки

Задання висоти рядка по замовченню

  1. У вікні відкритої таблиці виділіть потрібний стовпець або діапазон стовпців.
  2. Відкрийте меню Формат і в списку команд наведіть курсор на пункт Строка.
  3. У додатковому меню виберіть пункт Высота.
  4. У віконці Высота строки активуйте пункт По умолчанию.
  5. Закрийте вікно кнопкою ОК.

Як приховати рядок

  1. У вікні відкритої таблиці виділіть потрібний рядок або діапазон рядків.
  2. Відкрийте меню Формат і списку команд наведіть курсор на пункт Строка.
  3. У додатковому меню виберіть пункт Скрыть.
    Приховані рядки перестануть відображатися разом зі своїми номерами, а також з інформацією, яка міститься в них . При цьому зв'язки в формулах та функції, що встановлені з прихованими комірками, не будуть порушені.

Як показати діапазон прихованих рядків
Даний спосіб підходить, якщо діапазон прихованих рядків відомий.

  1. У вікні відкритої таблиці виділіть діапазон рядків, що включає приховані рядки.
  2. Відкрийте меню Формат і списку команд наведіть курсор на пункт Строка.
  3. У додатковому меню виберіть пункт Показать.

Як показати всі приховані рядки Даний спосіб підходить, якщо діапазон прихованих рядків невідомий або необхідно відобразити всі приховані рядки.

  1. У вікні відкритої таблиці виділіть все табличне поле.
  2. Відкрийте меню Формат і в списку команд наведіть курсор на пункт Строка.
  3. У додатковому меню виберіть пункт Показать.

Як вставити рядок
Перший спосіб

  1. У вікні відкритої таблиці виділіть потрібний рядок, вище якого необхідно додати новий.
  2. Відкрийте меню Вставка.
  3. У списку команд виберіть пункт Строка.

Другий спосіб

  1. У вікні відкритої таблиці клацніть правою кнопкою миші по рядку, вище якого необхідно додати новий.
  2. У контекстному меню виберіть пункт вставить строки.
    Щоб вставити кілька рядків одночасно необхідно попередньо виділити потрібну кількість рядків.

Закріплення рядка на екрані
Фіксація рядків на екрані дозволяє працювати з довгими стовпчиками даних, які не вміщаються в області перегляду електронної таблиці.

  1. У вікні відкритої таблиці виділіть рядок нижче того, який буде зафіксований. Наприклад, якщо необхідно закріпити на аркуші рядок 4, виділіть рядок 5.
  2. Відкрийте меню Окно і виберіть пункт Фиксировать.
    Всі рядки вище вибраного будуть зафіксовані з областю, яка не прокручується.

Транспонування значення рядків у стовпці Транспонування - це обмін місцями рядків і стовпців. При цьому відбувається копіювання значень комірок, розташованих у рядках, в заданий діапазон комірок з розташуванням по стовпцях або навпаки.

  1. У вікні відкритої таблиці виділіть діапазон комірок для транспонування.
  2. Відкрийте меню Правка і виберіть пункт Вырезать.
  3. Виберіть на табличному полі комірку, яка після транспонування повинна стати верхньою зліва.
  4. Відкрийте меню Правка і виберіть пункт Вставить как.
  5. У вікні Вставить как (Рис. 2.2.2) активуйте пункти Вставить все і Транспонировать.
  6. Закрийте вікно кнопкою ОК.
Рис. 2.2.2 Вікно Вставить как

Видалення рядка
Перший спосіб

  1. У вікні відкритої таблиці виділіть потрібний рядок.
  2. Відкрийте меню Правка.
  3. У списку команд виберіть пункт Удалить ячейки.

Другий спосіб

  1. У вікні відкритої таблиці клацніть правою кнопкою миші по необхідному рядку.
  2. У контекстному меню виберіть пункт Удалить строки.
    Щоб видалити кілька рядків одночасно необхідно попередньо виділити потрібну кількість рядків.

Швидке видалення вмісту рядка
У вікні відкритої таблиці виділіть потрібний рядок або діапазон рядків та натисніть клавішу Backspace.

Вибіркове очищення рядків

  1. У вікні відкритої таблиці виділіть потрібний рядок і натисніть клавsшу Delete.
  2. У вікні Удалить содержимое (Рис. 2.2.3) у групі Выбор виберіть потрібний параметр видалення:
    • Удалить все - для повного видалення вмісту рядка;
    • Текст - для видалення тільки тексту (формати, формули, числа і дати не видаляються);
    • Числа - для видалення тільки чисел (формати і формули не видаляються);
    • Дата и время - для видалення тільки дат і значень часу (формати, текст, числа і формули не видаляються);
    • Формулы - для видалення тільки формул (текст, числа, формати, дати та час не видаляються);
    • примечания - для видалення тільки приміток до комірок рядка (всі інші елементи не видаляються);
    • Форматы - для видалення тільки атрибутів формату, що застосовуються до комірок рядка (комірки не видаляються);
    • Объекты - для видалення тільки об'єктів (комірки не видаляються).
  3. Закрийте вікно кнопкою ОК.
Рис. 2.2.3 Вікно Удалить содержимое

Робота з стовпцями

Стовпець - це вертикальний ряд комірок від рядка 1 до рядка 65 536.

Виділення стовпця
Перший спосіб
У вікні відкритої таблиці клацніть на ім'я потрібного стовпця один раз лівою кнопкою миші з курсором-стрілкою.
Другий спосіб
У вікні відкритої таблиці виділіть будь-яку комірку потрібного стовпця і використайте клавіші Shift + Ctrl + Space.
Третій спосіб

  1. У вікні відкритої таблиці клацніть курсором введення тексту в адресномe віконці на рядку формул.
  2. Введіть адресу стовпця, наприклад: F1:F65536, де F1 вказує на першу комірку стовпця, а F65536 - на останню клітинку.
    Назву стовпця можна вводити без урахування регістру.
  3. Закріпіть введення натисненням клавіші Enter.

Виділення кількох стовпців підряд
Перший спосіб
У вікні відкритої таблиці протягніть курсор-стрілку по іменах потрібних стовпців при натиснутій лівій кнопці миші.
Даний спосіб зручний для виділення стовпців в межах видимості на аркуші.
Другий спосіб

  1. У вікні відкритої таблиці клацніть курсором введення тексту в адресному віконці на рядку формул.
  2. Наберіть адресу діапазону стовпців: адресу першої комірки першого стовпця, двокрапка, адресу останньої комірки останнього стовпця, наприклад C1:E65536, де C1 вказує на першу комірку першого стовпця діапазону, а E65536 - на останню комірку останнього стовпця.
  3. Закріпіть введення натисненням клавіші Enter.
    Даний спосіб зручний для виділення стовпців за межами видимості на аркуші.

Виділення кількох стовпців не підряд
У вікні відкритого аркуша клацайте по іменам потрібних стовпців курсором-стрілкою, утримуючи клавішу Ctrl.

Ширина стовпця
Ширина стовпців задається в сантиметрах. Вона може бути точною,вільної та оптимальною.

Як швидко змінити ширину стовпця
У вікні відкритої таблиці наведіть курсор миші на розділювач за ім'ям потрібного стовпця і при натиснутій лівій кнопці миші перетягніть вправо, вліво або вниз.

Як швидко підігнати ширину до вмісту стовпця
У вікні відкритої таблиці наведіть курсор на розділювач за ім'ям потрібного стовпця і двічі клацніть лівою кнопкою миші.

Задання точної ширини стовпця

  1. У вікні відкритої таблиці виділіть потрібний стовпець або діапазон стовпців.
  2. Відкрийте меню Формат і в списку команд наведіть курсор на пункт Столбец.
  3. У додатковому меню виберіть пункт Ширина.
  4. У вікні Ширина столбца (Рис. 2.3.1) поставте потрібне значення регулятором Ширина.
    Максимальна ширина стовпця дорівнює 100 см.
  5. Закрийте вікно кнопкою ОК.
Рис. 2.3.1 Вікно Ширина столбца

Як приховати стовпець

  1. У вікні відкритої таблиці виділіть потрібний стовпець або діапазон стовпців.
  2. Відкрийте меню Формат і в списку команд наведіть курсор на пункт Столбец.
  3. У додатковому меню виберіть пункт Скрыть.
    Приховані стовпці перестануть відображатися разом зі своїми іменами, а також з інформацією, яка міститься в них. При цьому не будуть порушені зв'язки з прихованими комірками в формулах і функціях.

Як показати діапазон прихованих стовпців
Даний спосіб підходить, якщо діапазон прихованих стовпців відомий.

  1. У вікні відкритої таблиці виділіть діапазон стовпців, що включає в себе приховані стовпці.
  2. Відкрийте меню Формат і в списку команд наведіть курсор на пункт Столбец.
  3. У меню, виберіть пункт Показать.

Як показати всі приховані стовпці
Даний спосіб підходить, якщо діапазон прихованих стовпців невідомий або необхідно відобразити всі приховані стовпці.

  1. У вікні відкритої таблиці виділіть все табличне поле.
  2. Відкрийте меню Формат і в списку команд наведіть курсор на пункт Столбец.
  3. У додатковому меню виберіть пункт Показать.

Вставка стовпця
Перший спосіб

  1. У вікні відкритої таблиці виділіть потрібний стовпець, ліворуч від якого необхідно додати новий.
  2. Відкрийте меню Вставка.
  3. У списку команд виберіть пункт Столбец.

Другий спосіб

  1. У вікні відкритої таблиці клацніть правою кнопкою миші по стовпцю, ліворуч від якого необхідно додати новий.
  2. У контекстному меню виберіть пункт Вставить столбцы.
    Для вставки декількох стовпців одночасно необхідно попередньо виділити потрібну кількість стовпців.

Закріплення стовпця на екрані
Фіксація стовпців на екрані дозволяє працювати з довгими рядками даних, які не вміщаються в видимій області електронної таблиці.

  1. У вікні відкритої таблиці виділіть стовпець праворуч від того, який буде зафіксований, наприклад, якщо необхідно закріпити на аркуші стовпець 10, виділіть стовпець 11.
  2. Відкрийте меню Окно і виберіть пункт Фиксировать.
    Всі стовпці ліворуч від обраного будуть зафіксовані з областю, яка не прокручується.

Видалення стовпця
Перший спосіб

  1. У вікні відкритої таблиці виділіть потрібний стовпець.
  2. Відкрийте меню Правка.
  3. У списку команд виберіть пункт Удалить ячейки.

Другий спосіб

  1. У вікні відкритої таблиці клацніть правою кнопкою миші на потрібному стовпцю.
  2. У контекстному меню виберіть пункт Удалить столбцы.
    Для видалення декількох стовпців одночасно необхідно попередньо виділити потрібну кількість стовпців.

Як швидко видалити вміст стовпця
У вікні відкритої таблиці виділіть потрібний стовпець або діапазон стовпців та натисніть клавішу Backspace. Як вибірково очистити стовпці

  1. У вікні відкритої таблиці виділіть потрібний стовпець або діапазон стовпців і натисніть клавішу Delete.
  2. Далі дійте відповідно до інструкції «Як вибірково очистити рядок ».

Робота з комірками

Комірка - це прямокутна область на табличному полі, що утворюється при перетині стовпця і рядка. Кожна комірка має власну адресу, тобто координати, які визначають її розташування на аркуші та в таблиці. Наприклад, адреса E9 означа, що дана комірка знаходиться на перетині стовпця E і рядка 9.
Комірки таблиць в Calc можуть містити текст, числа і дати. При цьому числа і дати в комірках автоматично вирівнюються по правому краю, а текст - по лівому.
У числах використовується кома (в англійській версії - крапка), а в датах - крапка (в англійській версії - коса риска, слеш). В кінці дати крапка не ставиться!
При недотриманні цих умов неправильне число і дата будуть сприйматися програмою як текст і, відповідно, автоматично вирівнюватися по лівому краю.
Число, сприйняте як текст (з крапкою як роздільник), не може бути використано в розрахунках.
Комірки можна додавати, видаляти і перетягувати разом з вмістом.
Інформацію, розташовану в комірках, можна представляти в різних форматах: числовому, дати і часу, текстовому, процентному і т. д.
Як задати розмір комірки
Розмір комірки визначається розміром стовпця і рядка. Тому для зміни її розмірів задайте потрібну висоту рядка і ширину стовпця.
Як швидко змінити розмір комірки
У вікні відкритої таблиці виділіть потрібну комірку і при натиснутій клавіші Alt натисканням клавіш зі стрілками змініть її розміри.

Виділення комірок

Маркер виділення - це чорна рамка виділеної в даний момент комірки. Він вказує на місце введення інформації на аркуші і комірку, призначену для форматування.

Виділення комірки на табличному полі
У вікні відкритої таблиці клацніть на потрібній комірці при натиснутій клавіші Shift.
Необхідно розрізняти виділення комірки і виділення комірки маркером. У першому випадку поле комірки стає затіненим, у другому - ні.
Виділену комірку можна переміщати за допомогою миші, а виділену тільки маркером - ні.

Виділення комірки маркером
Перший спосіб
У вікні відкритої таблиці клацніть на потрібній комірці лівою кнопкою миші.
Даний спосіб зручний для виділення комірок у межах видимості на табличному полі.

Другий спосіб

  1. У вікні відкритої таблиці клацніть курсором введення тексту в адресному віконці на рядку формул.
  2. Введіть адресу потрібної комірки, наприклад BG18.
    Назву стовпця в адресі можна вводити без урахування регістру.
  3. Закріпіть введення натисненням клавіші Enter.
    Даний спосіб зручний для виділення комірок за межами видимості на табличному полі.

Третій спосіб

  1. У вікні відкритої таблиці клацніть курсором введення тексту в адресному віконці на рядку формул.
  2. Введіть адресу потрібного діапазону клітинок, наприклад G4:K18, де G4 вказує на першу (верхню ліву) клітинку діапазону, а K18-на останню (нижню праву).
  3. Закріпіть введення натисненням клавіші Enter.

Виділення комірок, розташованих не поруч

  1. У вікні відкритої таблиці виділіть клацанням першу комірку.
  2. При натиснутій клавіші Ctrl клацніть по іншим потрібним для виділення коміркам.
    При виділенні групи комірок в адресному віконці на рядку формул відображається адреса тільки останньої виділеної комірки діапазона.

Виділення всіх комірок аркуша
У вікні відкритого аркуша клацніть на нульовій комірці Виделить всеабо скористайтесь комбінацією клавіш Ctrl + A.

Переміщення по комірках

Під переміщенням по комірках мається на увазі переміщення маркера активної комірки.

Швидкий перехід до відмічеченої маркером комірки
Дуже часто при прокручуванні аркуша з великим масивом даних виділена (активна) в даний момент комірка зникає з поля зору. Для швидкого переходу до неї використовуйте клавіші Ctrl + Backspace.

Як налаштувати потрібне переміщення маркера виділення
Як правило, після введення в комірку інформації або створення формули натискається клавіша Enter, і відбувається автоматичний перехід маркера виділення до комірки, розташованої за стовпцем нижче. Цей стандартний напрямок зміщення маркера можна змінити і задати переміщення вправо, вліво або вниз. Або ж залишати його на місці навіть після введення інформації та натискання клавіші Enter.

Як налаштувати використання клавіші Enter

  1. У вікні відкритої таблиці розкрийте меню Сервис.
  2. У списку команд виберіть пункт Параметры.
  3. У лівій частині вікна Параметры відкрийте список OpenOffice.org Calc і виберіть пункт Общие.
  4. У правій частині вікна у групі Настройка ввода активуйте пункт Клавиша Enter перемещает выделение.
  5. Відкрийте список праворуч від даного пункту і оберіть потрібний напрямок зсуву (Рис. 3.3.1).
  6. Закрийте вікно кнопкою ОК.
Рис. 3.3.1 Вікно Параметры Список направлений сдвига клавиши Enter

Як задати режим редагування у комірці Для внесення поправки в комірку необхідно двічі клацнути в її полі. Але можна задати для цих цілей використання клавіші Enter.

  1. У вікні відкритої таблиці розкрийте меню Сервис.
  2. У списку команд виберіть пункт Параметры.
  3. У лівій частині вікна Параметры відкрийте список OpenOffice.org Calc і виберіть пункт Общие.
  4. У правій частині вікна у групі Настройка ввода активуйте пункт Клавиша Enter перемещает выделение.
  5. Закрийте вікно кнопкою ОК.

Закріплення на екрані діапазону комірок
Окрім можливості закріплювати на екрані стовпці і рядки можливо закріплення і діапазону комірок, обмеженого по стовпцю і по рядку.

  1. У вікні відкритої таблиці виділіть комірку нижче потрібного обмежуючого рядка і праворуч від потрібного обмежуючого стовпця.
  2. Відкрийте меню Сервис.
  3. У списку команд виберіть пункт Фиксировать.
    Надалі при переміщенні вправо по стовпцях або вниз по рядкам на екрані завжди буде відображатися діапазон,заключений між обраними стовпцем і рядком. Знімається фіксація так само, як і фіксація стовпців і рядків, - відключенням пункту Фиксировать в меню Сервис.

Переміщування маркера активної комірки
Маркер активної комірки - це чорна рамка навколо комірки, яка відмічає комірку, виділену клацанням лівої кнопки миші. Він вказує, що саме в цю комірку буде вводитися інформація.
Маркер активної комірки можна переміщати по табличному полю за допомогою клавіш зі стрілками у бік напрямку стрілок.
За допомогою наступних клавіш маркер активної комірки можна перемістити:

  • - на одну комірку вправо;
  • - на одну комірку вліво;
  • - на одну комірку вгору;
  • - на одну комірку вниз;
  • Home - на початок рядка;
  • End - вправо в останній стовпчик, що містить дані;
  • Page Down - вниз на один повний екран;
  • Page Up - вгору на один повний екран;
  • Ctrl+→ — в останній стовпець, що містить дані в цьому рядку, або в останній стовпець таблиці (якщо даних немає);
  • Ctrl+← в перший стовпець, що містить дані в цьому рядку, або в стовпець A (якщо даних немає);
  • Ctrl+↑ — в перший рядок, що містить дані в цьому стовпці, або в рядок 1 (якщо даних немає);
  • Ctrl+↓ — в останній рядок, що містить дані в цьому стовпці,або в останній рядок таблиці (якщо даних немає);
  • Ctrl+Home — в першу комірку таблиці A1;
  • Ctrl+End — в нижній правий кут прямокутної області, що охоплює комірки з даними;
  • Alt+PgDn — на один екран праворуч (при можливості);
  • Alt + PgUp - на один екран ліворуч (при можливості);
  • Ctrl + PgDn - на один аркуш по таблиці вправо;
  • Ctrl + PgUp - на один аркуш по таблиці вліво;
  • Tab - в праву комірку;
  • Shift + Tab - в ліву комірку;
  • Enter - вниз на одну комірку;
  • Shift + Enter - вгору на одну комірку.

Об'єднання декількох комірок в одну
Кілька комірок, що стикаються між собою можна з'єднати в одну велику комірку із загальним форматом.

  1. У вікні відкритого аркуша виділіть потрібні суміжні комірки.
  2. Відкрийте меню Формат.
  3. У списку команд наведіть курсор на пункт Объединить ячейки (Рис. 3.3.2.).
Рис. 3.3.2 Меню Объединить ячейки

Вставлення нової комірки

  1. У вікні відкритого аркуша клацніть правою кнопкою миші в тому місці, де повинна розташовуватися нова комірка.
  2. У контекстному меню виберіть пункт Вставить ячейки.
  3. У вікні Вставить ячейки у групі Выбор (Рис. 3.3.3) виберіть:
    • Переместить ячейки вниз - для вставки комірок із зсувом вмісту вибраного діапазону вниз;
    • Переместить ячейки вправо - для вставки комірок із зсувом вмісту вибраного діапазону вправо;
    • Строка целиком - для вставки цілого рядка. Число рядків залежить від кількості попередньо виділених рядків на аркуші. Вміст вихідних рядків зсувається вниз;
    • Столбец целиком - для вставки цілого стовпця. Кількість стовпців залежить від кількості попередньо виділених стовпців на аркуші. Вміст вихідних стовпців зсувається праворуч.
  4. Закрийте вікно кнопкою ОК
Рис. 3.3.3 Вікно Вставить ячейки

Як швидко видалити інформацію з комірки
Видалення вмісту комірки не призводить до видалення самої комірки. У вікні відкритого аркуша виділіть потрібну комірку і натисніть клавішу Backspace.

Як вибірково очистити комірку

  1. У вікні відкритої таблиці виділіть потрібну комірку і натисніть клавишу Delete.
  2. Далі дійте за інструкцією «Як вибірково очистити рядок».

Введення і форматування даних в комірках

Як почати вводити в комірку інформацію
Щоб почати вводити текст, число або дату в комірку, нехідно виділити її, а потім на клавіатурі набрати потрібну інформацію або вставити значення, що знаходяться в буфері обміну.
Наприкінці введення необхідно натиснути такі клавіші:

  • Enter - для переміщення маркера вниз по стовпчику;
  • Shift + Enter - для переміщення маркера вгору по стовпчику;
  • Tab - для переміщення маркера вправо по рядку;
  • Shift + Tab - для переміщення маркера вліво по рядку.
    Після початку виведення інформації у виділену комірку на рядку

формул зліва від віконця введення автоматично активуються три кнопки:Вставка функций, Отмена, Ввод.
Якщо після закінчення вводу інформації не використовувати клавіші,а натиснути на кнопку Ввод на рядку формул, то маркер активної комірки її не покине, і комірка із введеними значеннями залишиться виділеною.
Якщо при введенні даних в комірку клацнути по кнопці Отмена на рядку формул до закріплення результату введення клавішами Enter та Tab, то набрана інформація буде видалена. Для цього також можна використовувати клавішу Esc.
Для видалення інформації, розташованої ліворуч від курсору введення текста, використовуйте клавішу Backspace, а для видалення інформації справавід курсора - клавішу Delete.

Автозавершення введеної інформації
При введенні часто повторюваних слів програма Calc пропонує закінчення слова, що набирається. Якщо продовження слова вас влаштовує, натисніть клавішу Enter і воно буде автоматично завершено. Автовведення розраховано на 2000 комірок або 200 рядків. При використанні функції автовведення великі/малі літери розрізняються.

Налаштування автовведення даних

  1. У вікні відкритої таблиці розкрийте меню Сервис.
  2. У списку команд наведіть курсор на пункт Содержимое ячейки.
  3. У додатковому меню активуйте пункт Автоввод.

Як користуватися автовведенням
При наборі повторюваного слова текст підстановки буде підсвічений синім кольором.
Для прийняття підстановки натисніть клавішу Enter або одну з клавіш переміщення курсору. Щоб додати текст або змінити підстановки натисніть клавішу F2.
Під час перегляду інших варіантів підстановки натисніть клавішу Tab для прокручування вперед або клавіші Shift + Tab для прокручування назад.
Щоб переглянути список всіх доступних текстових елементів автовведення за поточним стовпчиком використовуйте клавіші Ctrl + D.

Введення інформації у виділений діапазон комірок
При наборі у виділеному діапазоні комірок маркер виділення не покидає межі діапазону.

  1. У відкритому вікні аркуша виділіть потрібний діапазон комірок.
  2. Двічі натисніть клавішу Enter для переведення маркера активної комірки в початок діапазону.
  3. Введіть дані в активну клітинку та натисніть клавішу Enter.
  4. Після заповнення всіх комірок діапазону маркер виділення автоматино повернеться в першу клітинку (після натискання клавіші Enter або Tab).

Автозаповнення комірок
Якщо необхідно ввести в суміжні комірки повторювану інфорцію (текст, дати або числа), рекомендується використовувати функцію автозаповнення, яка автоматично створює ряди даних по заданому зразку.

Заповнення діапазона комірок за допомогою автозаповнення

  1. У вікні відкритого аркуша введіть дані в першу комірку ряду даних.
  2. Клацніть по будь-якій комірці, а потім знову виділіть комірку з введенними даними.
  3. Наведіть курсор миші на її правий нижній кут і, коли курсор стане тонким чорним хрестом, при натиснутій лівій кнопці миші

протягніть маркер заповнення вгору або вниз по стовпчику або вправо або вліво по рядку.

  1. Наприкінці потрібного діапазону відпустіть ліву кнопку миші.
    В даному випадку в нові комірки переносяться і значення, і формати вихідної комірки.

Автопродовження даних в комірках
Якщо автозаповнення повторює в нових комірках інформацію початкової комірки, то автопродовження створює нові дані, згідно з вибраним принципом: арифметична або геометрична прогресія, список дат і т. д.

Як редагувати введену інформацію
У вікні відкритої таблиці двічі клацніть на потрібній комірці з даними і, коли замигає курсор введення тексту, перемістіть його за допомогою клавіш зі стрілками в потрібне положення і внесіть виправлення.

Введення чисел

Створення арифметичної прогресії
Крім простого автозаповнення комірок даними при необхідності можна створити і арифметичну прогресію. Грунтуючись на встановленому зразку, Calc може автоматично продовжувати заповнення прогресії числами, комбінаціями чисел і тексту, датами і часом.

  1. У вікні відкритого аркуша введіть початкові значення створюваного ряду прогресії у першу і другу комірку діапазону, наприклад 1 і 2; 07:00 і 08:00; Пн і Вт; січень і лютий.
  2. Виділіть ці комірки і наведіть курсор на маркер заповнення данного діапазону.
  3. Курсором у вигляді тонкого чорного хреста при натиснутій лівій кнопці миші протяніть маркер заповнення по стовпчику (вгору або вниз) або по рядку (праворуч або ліворуч). Комірки заповняться даними за зростанням.
    Щоб використовувати принцип автозаповнення комірок, а не створення арифметичної прогресії, натисніть і тримайте клавішу Ctrl.

Створення геометричної прогресії

  1. У вікні відкритого аркуша введіть початкове значення створюваного ряду прогресії у першу комірку діапазону.
  2. Виділіть діапазон комірок, в якому буде розташовуватися геометрична прогресія.
  3. Відкрийте меню Правка і наведіть курсор на пункт Заполнить.
  4. У додатковому меню виберіть пункт Ряды.
  5. У вікні Заполнить ряды в групі Тип рядов (рис. 3.4.1) активуйте пункт Геометрический рост.
  6. У графі Приращение задайте число, на яке з кожним кроком буде збільшуватися значення в попередній комірці.
  7. Закрийте вікно кнопкою ОК.
Рис. 3.4.1 Вікно Заполнить ряды

Введення тексту

Вставка розриву рядка

  1. У вікні відкритої таблиці введіть перший рядок тексту в потрібній комірці.
  2. Для переходу на наступний рядок у комірці використовуйте сполучення клавіш Ctrl + Enter.

Введення чисел у форматі тексту
Число, яке необхідно записати в неформатному вигляді (наприклад, з символом 0 на початку), необхідно задати як текст. Після цього арифметичні операції з даним числом проводитися не будуть.

  1. У вікні відкритої таблиці клацніть правою кнопкою миші потрібній комірці або діапазону комірок.
  2. У контекстному меню виберіть пункт Формат комірок.
  3. У вікні Формат комірок на вкладці Числа (рис. 3.5.1) в групі Категория виберіть рядок Текстовый.
  4. Закрийте вікно кнопкою ОК.
Рис. 3.5.1 Вікно Формат ячеек Вкладка Числа

Введення дати і часу
Дата і час вводяться за допомогою чисел (18.11.08) і тексту (18. Нояб. 08). Як роздільник використовується крапка, двокрапка, слеш (/) та дефіс (-).

Створення автопродовження дат
Крім математичних рядів у таблицях часто використовуються списки дат, які можна також створювати автоматично.

  1. У вікні відкритого аркуша введіть початкове значення дати в першу комірку діапазону.
  2. Виділіть діапазон комірок, в якому буде розташовуватися список дат.
  3. Відкрийте меню Правка і наведіть курсор на пункт Заполнить.
  4. У додатковому меню виберіть пункт Ряды.
  5. У вікні Заполнить ряды в групі Тип рядов активуйте пункт Дата.
  6. У групі Единица времени виберіть потрібну одиницю виміру часу:
    • День - для створення семиденних рядів;
    • День недели - для створення п'ятиденних рядів;
    • Месяц - для створення рядів з повними або скороченими іменами місяців;
    • Год - для створення рядів років.
  7. У графі Приращение задайте число, на яке з кожним кроком буде збільшуватися значення в попередній комірці.
  8. Закрийте вікно кнопкою ОК.

Створення власного списку для автопродовження
Функція автопродовження будується на шаблоні списків в настройках Calc. Дані списки можна створювати, змінювати і видаляти.
Перший спосіб

  1. У вікні відкритої таблиці розкрийте меню Сервис.
  2. У списку команд виберіть пункт Параметры.
  3. У лівій частині вікна Параметры відкрийте список OpenOffice.org Calc і виберіть пункт Списки сортировки.
  4. У правій частині вікна в полі Элементы (рис. 3.5.2) введіть потрібний ряд даних і клацніть по кнопці Добавить.
    Створений список відобразиться в полі.
  5. Закрийте вікно кнопкою ОК.
Рис. 3.5.2 Вікно Параметры Списки сортировки

Другий спосіб

  1. У вікні відкритого аркуша створіть потрібний список даних і виділіть його.
  2. У вікні відкритої таблиці відкрийте меню Сервис і в списку команд виберіть пункт Параметры.
  3. У лівій частині вікна Параметры відкрийте список OpenOffice.org Calc і виберіть пункт Списки сортировки.
  4. У правій частині вікна навпроти графи Копировать список из клацніть на кнопку Копировать.
  5. Закрийте вікно кнопкою ОК.

Як корегувати список автопродовження

  1. У вікні відкритої таблиці розкрийте меню Сервис.
  2. У списку команд виберіть пункт Параметры.
  3. У лівій частині вікна Параметры відкрийте список OpenOffice.org Calc і виберіть пункт Списки сортировки.
  4. У полі Списки виділіть рядок потрібного списку рядів.
  5. У правій частині вікна в полі Элементы внесіть потрібні виправлення або доповнення та натисніть на кнопку Изменить.
  6. Закрийте вікно кнопкою ОК.

Як видалити список автопродовження

  1. У вікні відкритої таблиці розкрийте меню Сервис.
  2. У списку команд виберіть пункт Параметры.
  3. У лівій частині вікна Параметры відкрийте список OpenOffice.org Calc і виберіть пункт Списки сортировки.
  4. У правій частині вікна в полі Списки виділіть рядок потрібного списка рядів і натисніть на кнопку Удалить.
  5. Закрийте вікно кнопкою ОК.

Перенесення даних

Вирізання та копіювання
Щоб перенести текст або його фрагмент, а також графічні об'єкти або таблиці в нове місце документа, використовуйте вирізання або копіювання.
Вирізання - це перенесення безпосередньо тексту або об'єкту на нове місце документа.
Копіювання - це перенесення точної копії тексту або об'єкта в інше місце документа.

Налаштування умов копіювання посилань і перезапис даних при вставці

  1. У вікні відкритої таблиці розкрийте меню Сервис.
  2. У списку команд виберіть пункт Параметры.
  3. У лівій частині вікна Параметры відкрийте список OpenOffice.org Calc і виберіть пункт Общие.
  4. У правій частині вікна у групі Настройки ввода активуйте:
    • Копировать ссылки при вставке новых столбцов или строк - для розширення діапазону посилань при вставці стовпців або рядків поряд з даним діапазоном. Дане налаштування діє тільки при наявності в діапазоні посилань хоча б двох комірок в потрібному напрямку;
    • Показывать предупреждение о перезаписи данных при вставке - для попередження при вставці нових комірок у діапазон з існуючими даними.
  5. Закрийте вікно кнопкою ОК.

Копіювання та вирізання
Перший спосіб

  1. У вікні відкритого аркуша виділіть потрібний діапазон комірок.
  2. Клацніть правою кнопкою миші по виділеному фрагменту.
  3. У контекстному меню виберіть пункт Вырезать або Копировать.
  4. Клацніть правою кнопкою миші в тому місці аркуша таблиці, де повинні розташовуватися вирізані або скопійовані дані.
  5. У контекстному меню виберіть пункт Вставить.

Другий спосіб

  1. У вікні відкритого аркуша виділіть потрібний діапазон комірок.
  2. Натисніть кнопку Вырезать або Копировать на панелі Стандартная.
  3. Встановіть курсор у тому місці аркуша таблиці, де повинні розташуваться вирізані або скопійовані дані.
  4. Натисніть кнопку Вставить на панелі Стандартная.
    Можна використовувати сполучення клавіш Shift+Delete чи Ctrl+X (для вирізання), Ctrl+Insert або Ctrl+C (для копіювання) і Shift+Insert або Ctrl+V (для вставки).

Режим заміни

  1. У вікні відкритого аркуша виділіть потрібну комірку або групу комірок.
  2. Наведіть курсор на область виділеного діапазону і, утримуючи ліву кнопку миші, перетягніть клітинку або діапазон на нове місце, де і відпустіть.
  3. Інформація переміщеної комірки замінить дані в комірці.

Режим вставки

  1. У вікні відкритого аркуша виділіть потрібну комірку або групу комірок і почніть переміщення при натиснутій лівій кнопці миші.
  2. Натисніть і утримуйте клавішу Alt.
  3. Відпустіть комірки на новому місці.
  4. Існуючі комірки перемістяться вправо або вниз, а нові комірки залишаться на їх місці без заміщення інформації.

Режим копіювання

  1. У вікні відкритого аркуша виділіть потрібну комірку або групу комірок і почніть переміщення при натиснутій лівій кнопці миші.
  2. Натисніть і утримуйте клавішу Ctrl.
  3. Відпустіть комірки на новому місці.
  4. Відбудеться заміщення даних, як і при режимі вставки.

Режим посилання

  1. У вікні відкритого аркуша виділіть потрібну комірку або групу комірок і почніть переміщення при натиснутій лівій кнопці миші.
  2. Натисніть і тримайте клавіші Ctrl + Shift.
  3. Відбудеться заміщення даних посиланнями на вихідні клітинки.

Імена комірок

Присвоєння імені комірці або діапазону комірок

  1. У вікні відкритої таблиці виділіть потрібну комірку або діапазон комірок.
  2. Відкрийте меню Вставка і наведіть курсор на пункт Названия.
  3. У додатковому меню виберіть пункт Определить.
  4. У вікні Определить название (Рис. 3.7.1) в графі Имя наберіть потрібну назву.
  5. У графі Назначен на відобразиться посилання на виділений діапазон у вигляді абсолютного значення.
  6. Натисніть кнопку Дополнительно і в частині вікна, що розкриється у групі Тип области виберіть:
    • Диапазон печати - для визначення вибраної області як діапазону друку;
    • Фильтр - для визначення вибраної області в розширених фільтрах;
    • Повторить столбец - для визначення вибраної області як повторюваного стовпця;
    • Повторить строку - для визначення вибраної області як повторюється рядка.
  7. Натисніть кнопку Добавить.
  8. Закрийте вікно кнопкою ОК.
    При введенні створеного імені у формулу в якості автовведення все ім'я відобразиться в якості підказки.
Рис.3.7.1 Вікно Определить название

Налаштування розпізнавання імен при адресації
Можна налаштувати автоматичне розпізнавання імен заголовків стовпців при адресації. Дане налаштування активне по замовчуванню. Заголовок повинен починатися з літери і складатися тільки з літер і цифр. Наприклад, якщо в комірці А1 знаходиться текст «Продажі», а в осередках А2, А3 і А4 розташовуються значення 100, 200 і 300, то у формулі можна використовувати не адреси всіх трьох комірок, а заголовок «Продажі». Тільки необхідно враховувати, що при ручному введенні заголовка у формулу його слід заключити в апострофи (').

  1. У вікні відкритої таблиці розкрийте меню Сервис.
  2. У списку команд виберіть пункт Параметры.
  3. У лівій частині вікна Параметры відкрийте список OpenOffice.org Calc і виберіть пункт Вычисления.
  4. У правій частині вікна активуйте пункт Автоматический поиск подписей для столбцов и строк (Рис. 3.7.2).
  5. Закрийте вікно кнопкою ОК.
Рис.3.7.2 Вікно Параметры. Пункт Автоматический поиск подписей для столбцов и строк

Створення імені для декількох діапазонів

  1. У вікні відкритої таблиці виберіть область, яка міститиме всі діапазони, яким потрібно присвоїти імена.
  2. Відкрийте меню Вставка і наведіть курсор на пункт Названия.
  3. У додатковому меню виберіть пункт Создать.
  4. У вікні Создать название (Рис. 3.7.3) виберіть потрібний пункт:
    • Строка сверху - для створення назви діапазонів з верхнього рядка. Кожен стовпець отримує окрему назву і посилання на комірку;
    • Столбец слева - для створення назви діапазонів з першого стовбця. Кожен рядок отримує окрему назву і посилання на комірку;
    • Строка снизу - для створення назви діапазонів з останнього рядка. Кожен стовбець отримує окрему назву і посилання на комірку;
    • Столбец справа - для створення назви діапазонів з останнього стовбця. Кожен рядок отримує окрему назву і посилання на комірку.
  5. Закрийте вікно кнопкою ОК.
Рис.3.7.3 Вікно Создать название

Перехід до діапазону клітинок за допомогою його імені

  1. У вікні відкритої таблиці розкрийте список адресного віконця на рядку формул.
  2. У списку імен виберіть клацанням потрібне ім'я.
  3. На табличному полі виділиться відповідний діапазон клітинок.

Перехід до діапазону клітинок за допомогою вікна Навігатор

  1. У вікні відкритої таблиці увімкніть вікно Навигатор.
    Використовуйте клавішу F5 або кнопку Навигатор на панелі Стандартная.
  2. У списку категорій відкрийте список Названия диапазона (Рис. 3.7.4).
  3. Двічі клацніть на ім'я потрібного діапазону для виділення відповідних комірок на табличному полі.
Рис.3.7.4 Вікно Навигатор. Список Названия диапазона

Примітки

Налаштування відображення мітки примітки
Комірка з примітками в таблиці аркуша відрізняється червоною крапкою у верхньому правому куті. Цю позначку можна відключати або включати.

  1. У вікні відкритої таблиці розкрийте меню Сервис.
  2. У списку команд виберіть пункт Параметры.
  3. У лівій частині вікна відкрийте список OpenOffice.org і виберіть пункт Общие.
  4. У правій частині вікна у групі Справка активуйте пункт Всплывающие подсказки.
  5. Потім у лівій частині вікна відкрийте список OpenOffice.org Calc і виберіть пункт Вид.
  6. У правій частині вікна у групі Показать активуйте пункт Метка примечания.
  7. Закрийте вікно кнопкою ОК.

Як додати примітку до комірки
Перший спосіб

  1. У вікні відкритого аркуша клацніть правою кнопкою миші на потрібній комірці.
  2. У контекстному меню виберіть пункт Добавить примечание.
  3. У відкритому текстовому полі примітки (Рис. 3.8.1) наберіть потрібну інформацію.
  4. Для завершення введення тексту клацніть по будь-якій вільній комірці аркуша лівою кнопкою миші.

Другий спосіб

  1. У вікні відкритого аркуша виділіть потрібну комірку.
    Відкрийте меню Вставка і в списку команд виберіть пункт Примечание.
  2. Далі дійте так само, як у першому способі.
Рис.3.8.1 Текстове поле примітки до комірки

Відображення примітки
Примітка відображається при наведенні курсору на комірку з приміткою. Також можна задати постійний перегляд примітки.

  1. У вікні відкритого аркуша клацніть правою кнопкою миші по комірці з приміткою.
  2. У контекстному меню виберіть пункт Показать примечание.

Перегляд примітки за допомогою вікна Навігатор

  1. У вікні відкритої таблиці увімкніть вікно Навигатор.
  2. У списку категорій розкрийте список Примечания.
  3. Двічі клацніть по приміткі для переміщення маркера виділення у відповідну комірку, що містить вибрану примітку.
    Адреса виділеної примітки відобразиться на панелі вікна Навигатор

Зміна тексту існуючої примітки

  1. У вікні відкритого аркуша відобразіть потрібну примітку.
  2. Двічі клацніть у текстовому полі примітки і відредагуйте текст.
  3. Клацніть по будь-якій комірці аркуша.

Форматування тексту примітки

  1. У вікні відкритого аркуша відобразіть потрібну примітка.
  2. Двічі клацніть у текстовому полі примітки.
  3. Використовуючи панель Форматирование, застосувати необхідні формати до тексту.

Встановлення захисту на примітку

  1. У вікні відкритого аркуша відобразіть потрібну примітка.
  2. Клацніть правою кнопкою миші по області текстового поля примітки і в контекстному меню виберіть пункт Положение и розмер.
  3. У вікні Выноски на вкладці Положение и розмер (Рис. 3.8.2) в групі Защита активуйте потрібні пункти:
    • Положение - для заборони зміни положення або розміру примітки;
    • Размер - для заборони зміни розмірів примітки.
  4. Закрийте вікно кнопкою ОК.
Рис.3.8.2 Вікно Выноски. Вкладка Положение и размер

Формат приміток

Швидка зміна розміру текстового поля примітки

  1. У вікні відкритого аркуша відобразіть потрібну примітку.
  2. Клацніть по рамці примітки, а потім наведіть курсор на одну з вузлових точок, розташованих по периметру текстового поля і коли він стане двосторонньою стрілкою (діагональною, горизонтальною або вертикальною - залежно від обраної вузлової точки), при натиснутій лівій кнопці миші змініть розміри текстового поля.

Як поставити точний розмір текстового поля примітки

  1. У вікні відкритого аркуша відобразіть потрібну примітку.
  2. Клацніть правою кнопкою миші по області текстового поля примітки і в контекстному меню виберіть пункт Положение и размер.
  3. У вікні Выноски на вкладці Положение и размер у групі Размер регуляторами Высота і Ширина задайте потрібні значення.
  4. Для пропорційної зміни розмірів рекомендується включити пункт Пропорционально.
  5. Закрийте вікно кнопкою ОК.

Задання заливки текстового поля примітки

  1. У вікні відкритого аркуша відобразіть потрібну примітку.
  2. Клацніть правою кнопкою миші по області текстового поля примітки і в контекстному меню виберіть пункт Область.
  3. У вікні Область на вкладці Область (Рис. 3.9.1) у групі Заливка виберіть у палітрі потрібний колір.
  4. На вкладці Прозрачность (рис. 3.9.2) у групі Режим прозрачности при необхідності задайте ступінь прозорості заливки.
  5. Або активуйте пункт Градиент і сформуйте градієнтну заливку.
  6. На вкладках Штриховка (Рис. 3.9.3) і Текстура (Рис. 3.9.4) можна також вибрати візерунок або малюнок для фону примітки.
  7. Закрийте вікно кнопкою ОК.
Рис.3.9.1 Вікно Область. Вкладка Область
Рис.3.9.2 Вікно Область. Вкладка Прозрачность
Рис.3.9.3 Вікно Область. Вкладка Штриховка
Рис.3.9.4 Вікно Область. Вкладка Текстура

Задання ліній рамки і стрілок примітки

  1. У вікні відкритого аркуша відобразіть потрібну примітку.
  2. Клацніть правою кнопкою миші по області текстового поля примітки і в контекстному меню виберіть пункт Линия.
  3. У вікні Линия на вкладках Линия (Рис. 3.9.5), Стили линии (Рис. 3.9.6) і Стили стрелок (Рис. 3.9.7) задайте потрібні параметри рамки примітки.
  4. Закрийте вікно кнопкою ОК.
Рис.3.9.5 Вікно Линия. Вкладка Линия
Рис.3.9.6 Вікно Линия. Вкладка Стили линии
Рис.3.9.7 Вікно Линия. Вкладка Стили стрелок

Задання внутрішніх полів текстового поля примітки

  1. У вікні відкритого аркуша відобразіть потрібну примітку.
  2. Клацніть правою кнопкою миші по області текстового поля примітки і в контекстному меню виберіть пункт Текст.
  3. У вікні Текст на вкладці Текст (Рис. 3.9.8) в групі Расстояние до рамки задайте регуляторами потрібні значення чотирьох полів.
  4. Закрийте вікно кнопкою ОК.
Рис.3.9.8 Вікно Текст. Вкладка Текст

Задання параметрів розташування тексту в примітці

  1. У вікні відкритого аркуша відобразіть потрібну примітку.
  2. Клацніть правою кнопкою миші по області текстового поля примітки і в контекстному меню виберіть пункт Текст.
  3. У вікні Текст на вкладці Текст у групі Текст виберіть потрібне значення:
    • Выровнять ширину по тексту - для розтягування рамки примітки завширшки по ширині тексту, якщо поле примітки менше тексту;
    • Выровнять высоту по тексту - для розтягування рамки примітки у висоту по висоті тексту, якщо поле примітки менше тексту;
    • Подогнать по рамке - для зміни розміру тексту по полю примітки.
  4. Закрийте вікно кнопкою ОК.

Зміна розташування текстового поля примітки

  1. У вікні відкритого аркуша відобразіть потрібну примітку.
  2. Наведіть курсор на рамку текстового поля примітки і при натиснутій лівій кнопці миші перетягніть його на нове місце.

Як скопіювати примітку

  1. У вікні відкритого аркуша клацніть правою кнопкою миші по комірці з потрібною приміткою.
  2. У контекстному меню виберіть пункт Копировать.
  3. Клацніть правою кнопкою миші на новій комірці і в контекстному меню виберіть пункт Вставить как.
  4. У вікні Вставить как (Рис. 3.9.9) у групі Выбор відключіть пункт Вставить все і активуйте пункт Примечания.
  5. Закрийте вікно кнопкою ОК.
Рис.3.9.9 Вікно Вставить как. Пункт Примечания

Як видалити примітку

  1. У вікні відкритого аркуша клацніть правою кнопкою миші по комірці з приміткою.
  2. У контекстному меню виберіть пункт Удалить примечание.